How to permanently dismiss v1 upgrade banner (self-host)


Describe the problem/error/question

I’m self-hosting n8n and have upgraded to v1 (1.1.1). The info banner with n8n has been updated to version 1, introducing some breaking changes. Please consult the migration guide for more information. shows up on every page load, no matter how many times I dismiss it.

Is there a way to permanently dismiss this warning? I’ve tried on numerous browsers so as far as I can tell this isn’t a cookie issue.

Information on your n8n setup

  • n8n version: 1.1.1
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Linux

Hey @Josh,
there should be a Don't show again link in the banner that permanently dismisses it but it’s available only for the instance owners.
So if you are not seeing it I guess you are not logged in as owner or your instance doesn’t have an owner account. Can you check those things first?

Thanks @milorad. I logged in with my owner account but I’m still not seeing that Don't show again link (see screenshot)

Just a quick update: I tried this again and did a hard refresh after logging in as owner, after which I got the Don't show again link.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.