How to run in laptop the new version of n8n (0.203.0)?

Hi everyone, I was trying to install new version of n8n (0.203.0) by downloading from github. Right now I’m using version 0.168.0 of n8n and I want to migrate to the new version. When downloading and unzipping the github file, I performed the following steps to use dev mode:

1° - I installed the newest version of nodejs (18.12.1)
2° - I installed git (2.38.1)

3° - I installed n8n and lerna globally with the command npm install n8n -g and npm install -g lerna

4° - I entered the root folder and used the command lerna init

5° - Then I ran the command lerna bootstrap

After the 5th step I tried to run the command npm run build, but it didn’t work. What should I do?

I’m trying to use dev mode because I’m doing new nodes to my use and I need the new version (0.203.0), but it doesn’t work.

Is there other way to install locally the n8n? Because in Documentation a didn’t find a way.

Sorry to hear that you have problems. We moved away from lerna and npm and use now turbo repro and pnpm. You can check out the guide here.

Generally, the following steps should work:

rm -rf node_modules packages/**/node_modules
corepack enable && corepack prepare pnpm --activate
pnpm install
pnpm build
1 Like

Hi @Viniciusmq107, in addition to what @jan already said and seeing you are on Windows it’s probably worth adding that the corepack commands have to be executed as an administrator. In most cases you can simply right click on your terminal app and choose “Run as administrator” for this:

image

Also, I had to run corepack prepare [email protected] --activate on my current Node.js version 18.12.1 for this to work (without the @latest suffix I was running into a Usage Error: Invalid package manager specification in CLI arguments; expected a semver version, range, or tag error).

Hope this helps!