How to set proxy info for git node?


I wan’t to use the Git node but I’m behind a proxy .
I have already configure N8N for use proxy and he work fine, I go on web with n8n with no soucy. But with the Git node have problem, and i don’t know how to fix that.

Information on your n8n setup

  • **n8n version:183
  • **Database you’re using postgres

Hey @roxor45,

Have you tried using the config option in the Git node to set http.proxy to your proxy? It looks like there are a few options that can be set that might help although I have not tested them.

thanks for your help.
I have already try this option , and I get this error


Error: fatal: --local can only be used inside a git repository

    at Object.action (/usr/local/lib/node_modules/n8n/node_modules/simple-git/dist/cjs/index.js:1194:25)
    at PluginStore.exec (/usr/local/lib/node_modules/n8n/node_modules/simple-git/dist/cjs/index.js:1229:29)
    at /usr/local/lib/node_modules/n8n/node_modules/simple-git/dist/cjs/index.js:1590:43
    at new Promise (<anonymous>)
    at GitExecutorChain.handleTaskData (/usr/local/lib/node_modules/n8n/node_modules/simple-git/dist/cjs/index.js:1588:16)
    at GitExecutorChain.<anonymous> (/usr/local/lib/node_modules/n8n/node_modules/simple-git/dist/cjs/index.js:1572:44)
    at (<anonymous>)
    at fulfilled (/usr/local/lib/node_modules/n8n/node_modules/simple-git/dist/cjs/index.js:55:24)

Well that is annoying, What if you do it from an execute command node? From what I understand the library we use just uses the standard git command under it so you may be able to work around that way.

work great with execute command node.
I thinks it’s a bug

It looks like the library we use defaults to using --local on the addConfig() call, I suspect this could be to prevent someone from overwriting system wide settings. The good news is it does look like the library exposes that option so at some point in the future we could add that as an option.