How to start a workflow with a POST webhook?

I am trying to set up an automation that is triggered by RocketChat’s LiveChat Webhooks. They are POSTs and not GETs. I may just need a tutorial. I am trying to make a test POST from the LIveChat webhooks page successful as a trigger.

https://dsh.re/93430 - Screenshot of LiveChat settings

Below is the result of the test POST

https://webhook.site/#!/8ba2983f-f0f8-44a4-9e35-7e5eab3ffcbc/beebebb5-7232-4544-a3ac-57f0df462aa5/1

When I set up a node in n8n with No Authentication and use the URL in Postman I get the following.

ERROR: No credentials of type “httpBasicAuth” exist.

Error: No credentials of type "httpBasicAuth" exist.
    at getCredentials (/usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/NodeExecuteFunctions.js:80:15)
    at Object.getCredentials (/usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/NodeExecuteFunctions.js:418:24)
    at Object.webhook (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Webhook.node.js:257:40)
    at Workflow.runWebhook (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/src/Workflow.js:502:33)
    at Object.executeWebhook (/usr/local/lib/node_modules/n8n/dist/src/WebhookHelpers.js:47:48)
    at async /usr/local/lib/node_modules/n8n/dist/src/TestWebhooks.js:33:37

Postman returns:

{"code":0,"message":"Workflow Webhook Error: Workflow could not be started!"}

Welcome to the community @lquessenberry!

That is indeed a very strange problem. For some reason, it apparently tries to get credentials of type “httpBasicAuth” which it can not find. Which makes sense. Afterall you say you have it set to use no authentication. So it does not make any sense to me. I am also not able to reproduce it. So can you please select the nodes, copy them and then paste them directly here into the window. Maybe I have some luck reproducing it when I have exactly the nodes you are using.

You bet. Let me see if I can reproduce it once again.

{
  "nodes": [
    {
      "parameters": {
        "httpMethod": "POST",
        "path": "try",
        "responseMode": "lastNode",
        "options": {}
      },
      "name": "Webhook",
      "type": "n8n-nodes-base.webhook",
      "typeVersion": 1,
      "position": [
        560,
        240
      ]
    }
  ],
  "connections": {}
}

Ok, my mistake. Did test totally wrong.

So I can reproduce the problem when I set “Authentication” to “Basic Auth”. There seems to be a bug there that I will investigate. That, however, disappears as soon as I set it to “None”. Can you please make sure that you have it set to “None”, then save the workflow and then try again. The saving part is important as it reads the data for webhooks from the database. That really has to get changed again as it is very confusing. Sorry about that!

Ahaaaa I bet I wasn’t saving it! Gimme 2 seconds.

Boy I feel like a dummy. it was a lack of hitting SAVE. :stuck_out_tongue: Thanks man.

No sorry. It is, totally on me. It is supposed to take what is there and not what is saved in the database. Is currently very unintuitive and have to find a way again to make it work that way again!

1 Like

Well you can depend on me to help QA things. I like the software so far. Thanks for all your hard work.

Great, thanks a lot. Is great to hear and very appreciated!

Ok changed that. Works now as expected, without saving.

Will be released with the next version.

Got released with [email protected]