How to use Automatic proxy in n8n for Windows

Hi everybody,

I would like to show how n8n is so cool to my colleagues.

I want to try with the Windows installer version.

When I am at home it’s working well.
When I am at work the interface never show up. If i start from command it’s block on “waiting for tunnel”.

Our network is designed to take all the traffic with a local proxy.
In firefox or Chrome, I just have to tick “Automatic proxy detection”.

How can I perform the same with n8n for Windows ?
Or is there a workaround to set manually the proxy ?

Thank you,
Best,
Julien

Hi @JulienDelRio,

Sounds like the tunnel that is created automatically by the desktop app is being blocked by your IT department.

When you first start n8n, a hidden file is created that contains the tunnel information so inbound calls can go directly to your n8n desktop. It sounds like this first step is not happening and that is why the app is not deploying.

Your best bet maybe to run docker for windows and run it in docker, as you are able to set those proxy values manually in the setup, but it maybe more complicated than you want to deploy.

I wish I knew more about the desktop version, but I typically use the docker version so my knowledge on it is limited. Someone like @jon may know better about this.

Hi

I didn’t check your answers.

My computer at work is weak. Docker for windows doesn’t work well. That’s why i am looking for the windows version.

I will open an issue.

Ah I missed this one, So I suspect it could be the proxy blocking the tunnel creation. It could be worth checking with the IT team although I did think that we fixed an issue with Desktop where it wouldn’t start if it couldn’t create the tunnel.

Would you be able to open a command prompt window and run the app from there? You can do this by changing into the directory that contains the exe and just typing the name in.

1 Like

Hi,

Thanks for the reply.

I checked your answer on github.

I will try tomorrow at work and go back.

Thanks

1 Like

Hi Jon,

I tried. It’s not working.

Here the console output :

It seems the tunnel is not possible.

Is it possible to launch n8n without the tunnel ?

Hey @JulienDelRio,

That is a good question, I can’t see an option so it could be a hard coded option. I noticed you added a start in there if you drop that does it change anything? I am wondering if the issue isn’t with not using a proxy at all but more that the proxy is blocking the tunnel.

@ivov any thoughts on this?

To disable tunnelling in desktop, append DESKTOP_ENABLE_OFFLINE_MODE=true to the n8n-desktop.env in your .n8n dir.

1 Like

Hi,

I tried without “start” no change.

I will try the idea from ivov and go back.

Best

Thank you, it’s working like a charm.

My two cents.
In this page : Desktop app - n8n Documentation, you could add a message on how to disable tunnel for environnements where it is not possible to create it.

1 Like