HTML Extract Error

Im triying to extract url’s of multiple html website but i have the “no property named “data” exist!” error, please help.

Information on your n8n setup

  • **n8n version:0.209.4
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own]:
  • Running n8n via [desktop app]:

Hey @Exes_Educacion,

Do all of your items have the data property? Can you try disabling the expression on that field as well and see if that helps?

Yes, all the items have the same property,

What i have to try disable?

Change the JSON property to a fixed value by changing the option on the top right of the input field.


Its appears the same error

I tried eliminating items , and it works with some of them but all have the data property .

Why some works and others not?

Hey @Exes_Educacion,

Without seeing all of the items it is hard to say, Can you share one that works and one that doesn’t?

There ir a lot of urls without “www” and htttp (not https) like this one:

Not all of them but some of it doesn’t giving an output:

Its a bit rare because don’t follow a sense patron.

Hey @Exes_Educacion,

You have never error set so it won’t fail, Turning that off shows that the URL is sending a 302 header which is a redirect so you would need to enable redirects under the options. A good way to handle this would be to use the Include Response Headers and Status then in your next node you can do an If status code is between 200 and 299 continue to html extract.

We will be changing the HTTP Request node in one of the next releases to automatically redirect so you won’t need to worry about it but for the science you can find a workflow below that implements the above, Give it a play and see if it makes sense.

I add 200 items and appear this error:

{“status”:“rejected”,“reason”:{“message”:“getaddrinfo ENOTFOUND”,“name”:“Error”,“stack”:“Error: getaddrinfo ENOTFOUND\n at GetAddrInfoReqWrap.onlookup [as oncomplete] (node:dns:71:26)\n at GetAddrInfoReqWrap.callbackTrampoline (node:internal/async_hooks:130:17)”,“code”:“ENOTFOUND”}}

It is working correctly but in some case appears an error that i dont know to identify, ty

Hey @Exes_Educacion,

Is it the getaddrinfo error?

Hello Jon,

Yes i delete it and its working, also when the input contains aproximatly more than 50 website to fetch it appear this error:

Can you share the sheet with me?

Of course. (Empresas BBDD - Google Tabellen)

Hey @Exes_Educacion,

I have given that workflow a go using both sheets and I was not hitting the same error, Does the sheet you shared have any data removed?

I think its because im using my n8n with my own computer, something happen with my network?,
i dont know.

It could be that there it is an odd network issue it is hard to say but in theory it should work.

Yes, sorry, i delete some of the data.

Try now.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.