HTML formatting problem

Hi

I am trying to send some HTML raw data via HTTP request

The problem is that no matter what I do I get quotation marks and escaping characters

body sendreqestpdf ¨

This is the output i get from n8n
" “hallo” "

Making my request don’t work using N8n, when I use another tool then it works.

Any idea how to solve this?

@Mattias_Larsson it works for me. Am I missing something?

 {
  "nodes": [
    {
      "parameters": {},
      "name": "Start",
      "type": "n8n-nodes-base.start",
      "typeVersion": 1,
      "position": [
        250,
        300
      ]
    },
    {
      "parameters": {
        "requestMethod": "POST",
        "url": "https://webhook.site/d45c1b68-ecab-405e-8429-57cbec151fe5",
        "responseFormat": "string",
        "jsonParameters": true,
        "options": {
          "bodyContentType": "raw",
          "bodyContentCustomMimeType": "text/html"
        },
        "bodyParametersJson": "<html><body>\"ricardo\"</body></html>"
      },
      "name": "HTTP Request",
      "type": "n8n-nodes-base.httpRequest",
      "typeVersion": 1,
      "position": [
        590,
        300
      ]
    }
  ],
  "connections": {}
}

Possibly related to the unmatched closing angle bracket:

image

ahh good catch @ivov

Should additionally also not have the " around hello.

Hi

Thanks a saw the issues with the wrong characters. Still not solving the problem

When we try to send it with n8n it ending up with “” around the HTML text but when we use another tool doing exactly the same post we have no issues

{
  "nodes": [
    {
      "parameters": {
        "requestMethod": "POST",
        "url": "https://webhook.site/f2038034-563c-45b2-b1c2-500ab9c2cf63",
        "responseFormat": "file",
        "jsonParameters": true,
        "options": {
          "bodyContentType": "raw",
          "bodyContentCustomMimeType": "text/html"
        },
        "bodyParametersJson": "<html><body>hello</body></html>",
        "headerParametersJson": "={{ {\"name\": \"Test.pdf\"} }}"
      },
      "name": "GeneratePDF2",
      "type": "n8n-nodes-base.httpRequest",
      "typeVersion": 1,
      "position": [
        1170,
        450
      ]
    }
  ],
  "connections": {}
}

Ah, thanks for sending the example through. Totally misunderstood the problem wrong. That looks like a bug. We will try to fix asap.

1 Like

The problem was with “Response Format” -> “File”. If set to “String” it works fine.

Did fix the bug and will be released very soon.

1 Like

Okey thanks

Then i waite:)

Did also just build the nightly version. So you can for now use n8nio/n8n:nightly which already includes the fix.

Thanks will try

Got released with [email protected]

1 Like