HTML request with plain/text body


I am having an issue when sending a HTTP POST request.

I can replicate the issue using e.g., Thunder Client in Visual Studio Code and I have narrowed down the issue in a way that I need to send the request with the Body using text/plain.

I haven’t figured out how to send the request using the HTTP Request node.

Basically, I send this message:


and when trying to execute it from the node I only get this response:

INSERT INTO id_(trend,symbol,risk,sl,betrigger,trailtrig,traildist) VALUES(‘buy’,‘SWE30’,1,100,100,150,100":" "});

I don’t get the execution I want on the receiving end.

but when I send it as plain/text from another client I get the below response, basically two lines gets repeated but with the id attached on the first line.

INSERT INTO id_1231231312313(trend,symbol,risk,sl,betrigger,trailtrig,traildist) VALUES(‘buy’,‘SWE30’,1,100,100,150,100 );
INSERT INTO id_(trend,symbol,risk,sl,betrigger,trailtrig,traildist) VALUES(‘buy’,‘SWE30’,1,100,100,150,100 );

I have played around with different settings in the node but I haven’t managed to find any working way of sending the request just as “text/plain”.

I have attached one code snippet but I have tried so many different choices without any luck.

The first field consisting of multiple numbers is a serial number, I have concluded that if the serial number (first field) is not interpreted correct I get the the answer with a single line, basically that actual execution of the command failed.

Any idea/help on how I can send the HTTP request without getting stuck with the Form fields?

Hi @maxton, you are probably looking for the JSON/RAW Parameters option here:

You can check out the difference by using a service such as showing you the data arriving on the server.

Without JSON/RAW Parameters:

With JSON/RAW Parameters:


Fantastic! Yes, it works! I played around with these parameters but I didn’t find the right combo because I don’t really understand how all headers etc hangs together.

But yes, this was the solution!


1 Like

Awesome, glad to hear this works for you! Thx for confirming :slight_smile:

1 Like