HTTP Request 429 Error. Google Search

Describe the problem/error/question

Hi. I’m new here at n8n :slight_smile: we have a google search that grabs 10 linkedin addresses with every query. It works fine for a few queries, then the error comes up. The service is receiving too many requests from you. Error 429. Any ideas. Thanks, r

What is the error message (if any)?

{
“errorMessage”: “The service is receiving too many requests from you”,
“errorDetails”: {
“rawErrorMessage”: [
“Try spacing your requests out using the batching settings under ‘Options’”
],
“httpCode”: “429”
},
“n8nDetails”: {
“nodeName”: “HTTP Request”,
“nodeType”: “n8n-nodes-base.httpRequest”,
“nodeVersion”: 4.1,
“itemIndex”: 0,
“time”: “2.4.2024, 20:55:56”,
“n8nVersion”: “1.33.1 (Self Hosted)”,
“binaryDataMode”: “default”,
“stackTrace”: [
“NodeApiError: The service is receiving too many requests from you”,
" at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/HttpRequest/V3/HttpRequestV3.node.js:1571:35)“,
" at processTicksAndRejections (node:internal/process/task_queues:95:5)”,
" at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:724:19)“,
" at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:660:53”,
" at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:1062:20"
]
}
}

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
    1.33.1 (Self Hosted)
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
    Docker
  • Operating system:
    MacOS

The HTTP 429 means you’re getting rate limited - you’re firing off your requests to Google too quickly. This is because in your current workflow setup, all requests are handled at the same time. A better approach is to add a Loop over Items node to process the items one by one and adding a Waiting node to build in a delay between each request. I don’t think Google documents the search rate limits, so you’ll have to experiment a bit to get your wait value right.

1 Like

thanks for the info! i’ll give it a try.

1 Like