HTTP Request node doesn't includes the defined Accept header

Describe the problem/error/question

Hi, I’m trying to update a custom application which require certain value for the Accept header. Whilst I’d set it, but it constantly failed. I don’t know how n8n send the request as it seems the request was wrapped under run. I couldn’t see the actual call from Fiddler either.

Is there anyway to ensure my Accept header is included in the call? Thanks.

And it works in postman.

What is the error message (if any)?

Problem in node “HTTP Request”, Bad request - please check your parameters.

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.216.2
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): desktop app
  • Operating system: win 64

Found my solution in Override Accept Header in Http Request - #4 by jan


Hi @engowen - good to see you in the community again, and glad to hear you found the solution! Thanks for linking the thread so that others can find it, too. :smile:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.