HTTP Request Node Results Not Showing

Hi,

We deployed n8n to our own cloud through following the server deployment guide. After that I created our first testing workflow which contains simple HTTP Request Node to get users from https://reqres.in/api/users. But results not showing and process stays like;

I changed request url to my local development server then re-execute workflow and after that I saw that our server got request and returned 200. But HTTP Request node still not showing the results.

We checked docker logs and find;

[Rudder] error: got error while attempting send for 3 times, dropping 1 events

What we should do to fix that?

  • n8n version: 0.157.1
  • Database you’re using (default: SQLite): Postgres
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

If you use nginx reverse proxy, you may accidentally add forward slash to variable N8N_HOST should be sth like -e N8N_HOST="n8n.hryszko.dev" instead of -e N8N_HOST="n8n.hryszko.dev/" is it that?

variable defined as N8N_HOST=https://n8n.app.com

For me, it looks like problem with docker or nginx can you provide docker-compose.json file or docker running command?

My command was like following, you can check if something is different in your case, it may be helpful:

docker run \
--restart always \
--name n8n \
-p 127.0.0.1:5678:443 \
-e N8N_HOST="n8n.hryszko.dev" \
-e N8N_PORT=443 \
-e N8N_PROTOCOL="https" \
-e WEBHOOK_TUNNEL_URL="https://n8n.hryszko.dev/" \
-e VUE_APP_URL_BASE_API="https://n8n.hryszko.dev" \
-e NODE_FUNCTION_ALLOW_EXTERNAL="moment,lodash" \
-e N8N_CONFIG_FILES=/home/node/.n8n/conf.json \
-v /home/simon/n8n-local-files:/files \
-v ~/.n8n:/home/node/.n8n n8nio/n8n

here our docker-compose.yml file;

  n8n:
    image: n8nio/n8n
    restart: always
    environment:
      - DB_TYPE=postgresdb
      - DB_POSTGRESDB_HOST=db-host
      - DB_POSTGRESDB_PORT=db-port
      - DB_POSTGRESDB_DATABASE=db
      - DB_POSTGRESDB_USER=db-user
      - DB_POSTGRESDB_PASSWORD=db-pass
      - N8N_BASIC_AUTH_ACTIVE=false
      - WEBHOOK_URL=https://n8n.app.com/
      - N8N_HOST=https://n8n.app.com
    ports:
      - 5678:5678
    links:
      - postgres
    volumes:
      - ~/.n8n:/home/node/.n8n
    # Wait 5 seconds to start n8n to make sure that PostgreSQL is ready
    command: /bin/sh -c "sleep 5; n8n start"

Try to change - N8N_HOST=https://n8n.app.com to - N8N_HOST=n8n.app.com, plus add this: - N8N_PROTOCOL=https

See my docker_compose.json

docker_compose.json:

n8n:
    image: n8nio/n8n
    restart: always
    ports:
      - "127.0.0.1:5678:443"
    environment:
      - N8N_BASIC_AUTH_ACTIVE=true
      - N8N_BASIC_AUTH_HASH=true
      - N8N_BASIC_AUTH_USER
      - N8N_BASIC_AUTH_PASSWORD
      - N8N_HOST=${SUBDOMAIN}.${DOMAIN_NAME}
      - N8N_PORT=443
      - N8N_PROTOCOL=https
      - NODE_ENV=production
      - WEBHOOK_URL=https://${SUBDOMAIN}.${DOMAIN_NAME}/
      - GENERIC_TIMEZONE=${GENERIC_TIMEZONE}
      - NODE_FUNCTION_ALLOW_EXTERNAL=moment,lodash
      - EXECUTIONS_DATA_PRUNE=true
      - EXECUTIONS_DATA_PRUNE_TIMEOUT=604800
      - DB_SQLITE_VACUUM_ON_STARTUP=true
    volumes:
      - /home/${SERVER_USERNAME}/.n8n:/home/node/.n8n
      - /home/${SERVER_USERNAME}/n8n-local-files:/files

.env:

SERVER_USERNAME=simon
DOMAIN_NAME=hryszko.dev
SUBDOMAIN=n8n

Docs: Server Setup | Docs

thank you for your effort @Shirobachi :pray:

we actually had trouble from nginx configuration and found solution at here

1 Like

Happy it works, have fun :))

2 Likes