HTTP Request Proxy not working

Describe the issue/error/question

When setting a proxy (tested several alternatives) node timeout without error and will return empty result
Using curl with proxy inside the container is working just fine

What is the error message (if any)?

No error, just empty return: “This is an item, but it’s empty.”

Please share the workflow

Share the output returned by the last node

Expected output

<!doctype html>

Actual output

1 item
This is an item, but it’s empty.

Information on your n8n setup

  • n8n version: 0.193.3
  • Database you’re using (default: SQLite): Postgres
  • Running n8n with the execution process [own(default), main]: main
  • Running n8n via [Docker, npm,, desktop app]: Docker-compose

Hi @lero, I am afraid I don’t have access to a proxy server (I am actually somewhat surprised they are still in use). But I know @RicardoE105 worked a lot on the HTTP Request node recently, perhaps he has an idea what might cause this?

It was working fine in the past weeks. Unfortunately I’m not able to address after what update it stopped.
I use it to protect my server IP address. For now I’m running my workflow without it just fine.

Oh, I wonder if any of the recent changes have broken it, though from looking at n8n/ at master · n8n-io/n8n · GitHub nothing stands out to me. Do you happen to know roughly when you have previously upgraded n8n? That might help with getting an idea of which version you were running before.

Unfortunately I lost track of the updates applied. Wherever I see an update I just apply. I probably applied 2 or 3 updates before noticing the problem.

Looking at changelog maybe it broke after version 0.182.0

What are your proxy settings and what URL are you trying to hit?

It’s an internal proxy based on squid. And it’s working fine.
The url isn’t an issue either. I can use any url and the problem is the same.
As I stated in my first post I actually can use curl with my proxy inside n8n container with success for my target url and any url. I also tried other proxy addresses that I found through Google and all worked. It doesn’t work only with the HTTP Request node.

Asking because there are some know issues with making HTTPS requests via HTTP proxies with the newer axios library.

Hmmm… Makes sense. My proxy server handles HTTPS requests well. But the server proxy itself isn’t HTTPS.
Do you know how I can check if axios is the problem?