Http Request vs Insomina/Postman json response format?

I tried to make a GET call through HTTP Request node to get a json response format but encountered an error that the response is not valid json and to change to string format instead.

Tried string and gotten a response but when i try to manipulate the data via function node to map through to create items to be process in baserow (1 item for 1 row), I encountered lots of issue. Probably my knowledge in data manipulation is not great. Tried many methods to convert the data to proper json format.

I have also tried getting the response as file > then use the move binary data node to convert the file to json but also encountered problem (unexpected number in json). I was starting to think my response data is not formatted correctly.

But when I made the same GET call using insomnia, the return json is perfectly formatted. I tried by copying the response from insomnia and setting and returning via a function node. I can do what i intended to. Meaning its the correct json format.

Can anyone point me to where to look to get this right?

*The response data is pretty big. If need be I will post a shorten version and redact the value.
All i can tell from comparing the 2 responses are the additional key [{“data”:“{…}”}]
I like to know why insonmia or postman seem to be able to return a JSON response.

Anyway great project @jan !
I am testing out n8n coming from other automation tools but I really like the direction its going. Once I finish evaluating, will definitely hop on the cloud tier to support the team.

Best Regards

Hey @leonardchiu,

Welcome to the community :tada:

Are you able to share what you are trying to connect to or the full response from the HTTP Request node so we can take a look?

It does sound a bit odd, If the server is responding with the correct content type header we should treat it as json so it sounds like maybe something needs to be looked at there.

Probably the return json is not in the correct format. Let me investigate further before posting here.

1 Like

Hi, I get the same issue as OP.
Postman is able to break down the json correctly, showing “links” and “content” as per the json.
n8n bundles it all into a “data” field that doesn’t exists.
Any ideas why?