HTTP Request with oAuth2 stops working after some minutes

Describe the issue/error/question

As it isn’t possible to upload attachments to ZOHO CRM with the ZOHO node I created a HTTP Request node and configured a oAuth2 connection. The request works as expected but after some minutes the requests fail and the ZOHO API responds:

{
  "status": "rejected",
    "reason": {
  }
}

When I reconnect the connection in the node it works again for several minutes.

This is the node:

And my oAuth2 configuration:

Is my configuration wrong? From what I’ve understood so far the node should take care of refreshing the token.

Does anyone have an idea what could be wrong here? Many thanks!

Information on your n8n setup

  • n8n version: 0.158.0 (Cloud)

Hey @Gould, I just tried a workflow using credentials I hadn’t touched since a month (this one) and the OAuth2 credentials did not expire.

I wonder if Zoho’s API might require a special scope/query parameter for offline access/continued access without user interaction. For Google for example I needed to add a query parameter access_type=offline in the Auth URI Query Parameters field from your screenshot, otherwise no refresh token would be issued by Google (which is required to refresh the access token).

Do you have a link to the respective API documentation by any chance?

1 Like

@MutedJam, looks like the access_type=offline parameter is the solution. Great! It’s mentioned in the documentation but I didn’t understand the meaning: Authorization Request | Online Help - Zoho CRM

1 Like

@MutedJam Once more you have seemed to have already solved the exact issue I am running into :slight_smile:
Thanks!

1 Like