Hubspot contact-search causes API overload

When I utilize the “search” operation on a hubspot module, I always get this:

ERROR: The service is receiving too many requests from you! Perhaps take a break?
You have reached your secondly limit.

This is whatever the search is, I’ve tried limiting the number of results to 1 or 5, nothing makes a difference. The execution time is about 6000-7000ms before it says this.

Am I doing something wrong? Anyone else encounter this?

P.S Hubspot says this secondly error only happens in the API gets hit more than 10 times a second.

Hey @aleknovkovski,

Do you only have the Hubspot search in your workflow or are there more steps before it?

Yes, there are hubspot modules before it. I went and put those and pause and tested it that way, no longer causes the issue.

But I think it means I misunderstand how n8n works. It was set up like this:

  • Module to set latest contacts, limited to 5
  • Module to set latest engagements, limited to 5
  • This module set to search contacts, limited to 5

Individually they take miliseconds (if the other 2 are set paused). Does executing one cause the others to loop?

Hey @aleknovkovski,

That is exactly it so most of the nodes in n8n are designed to loop for each input so if you have one node outputting 10 items the next node is going to run 10 times. Normally this is what you would want to do but if you don’t need to do this there is an option under the Node settings to only run once which can help you work around it.