"Hubspot Developer Account" -> "Insufficient scopes were provided. Please contact the app developer."

I cannot authenticate with n8n cloud to a hubspot account. In the OAuth screen I get the message:

Insufficient scopes were provided. Please contact the app developer.

Hey @Julian_David_Rath,

I am sorry that you faced the issue. May I know which resource you’re trying to request? I’ll check the permissions and get them fixed.

None yet, just trying to add an “HubSpot Developer Account”,

Hey @Julian_David_Rath,

I tested it, and it is working for me as expected. Can you please let me know which version of n8n are you using? I will try to test against that version and see if I can replicate the issue.

(All fields are filled out, its just not in the picture)

Pressing the button in the bottom opens the oauth consent dialogue, and then I get the exception.

Looking at the screenshot, I can say that you’re using the HubSpot Trigger node (correct me if I am wrong). Since, for the HubSpot Trigger node you have to create your own credentials, you will also have to add additional scopes to the app that you created. Step 9 talks about scopes in this documentation: HubSpot | Docs

Yes, i have also looked at the OAuth URL n8n is using, it requests contacts nothing else…

Hey @Julian_David_Rath,

I created a new app in HubSpot, copied the Callback URL from n8n, and added the contacts scope. I then connected it with the node, and it worked as expected. According to the HubSpot documentation you only need the contacts scope.

I didn’t get the error that you received. While connecting, the request got blocked from HubSpot, but after refreshing page, it worked as expected.

Estou com o mesmo problema, alguém já conseguiu achar a solução?

Como adiciona o contacts escopo.?

Did you follow the steps in the docs?

Segui sim!

  1. Acesse a página [inicial do HubSpot Developer (abre uma nova janela)] (https://developers.hubspot.com/).:white_check_mark:

  2. Clique no botão Gerenciar aplicativos .:white_check_mark:

  3. Clique no botão Criar aplicativo no canto superior direito.:white_check_mark:

  4. Especifique um nome de aplicativo no campo Nome do aplicativo público .:white_check_mark:

  5. Clique na guia ‘Auth’.:white_check_mark:

  6. Use o ID de cliente fornecido e o segredo do cliente com suas credenciais da API HubSpot OAuth2 em n8n.:white_check_mark:

  7. Se você estiver usando o nó HubSpot Trigger , copie o ID do aplicativo junto com as informações da etapa anterior.:white_check_mark:

  8. Copie seu URL de retorno de chamada OAuth da tela “Criar novas credenciais” no n8n e cole na seção URL de redirecionamento .:white_check_mark:

  9. Na seção Escopos, certifique-se de que o escopo ‘Funcionalidade OAuth básica’ esteja selecionado na lista suspensa Adicionar um escopo necessário .:white_check_mark:

  10. Selecione quaisquer outros escopos que você planeja usar com o n8n…:white_check_mark:

  11. Clique no botão Salvar para salvar suas configurações no HubSpot…:white_check_mark:

  12. De volta ao n8n, clique no botão círculo na seção OAuth para conectar sua conta HubSpot ao n8n…:white_check_mark:

  13. Clique no botão Salvar para salvar suas credenciais.

Acontece estes erros!

For some reason your UI for adding the scopes it’s different than mine. In my HubSpot test account, under scopes, I have selected only: forms, contacts, and tickets. Can you please only select those 3?

Please do post messages here only in English! We extra created a forum for Spanish speaking people: https://es.community.n8n.io

Ah realize now that it is Portuguese. Please use then Google Translate to translate to English. Thanks!

Actually mine doesn’t appear that way, I get the forms, tickets but I don’t have the contacts option.

I apologize, I’ll post translated in the next ones, thanks!

I was checking Hubspot’s documentation and found out some interesting things:

  1. Scopes requested by app (n8n in this case) must match the ones we set on the app settings in Hubspot developers’ portal
  2. The contacts scope was migrated to more granular options since November 1st. My UI is just like Gustavo’s and I cannot select contacts as a scope.

I believe @RicardoE105 's app was created before November 1st and is therefore still enabled to use the contacts scope, but new apps won’t allow this.

I believe we will have to update our integration accordingly and add this information to our docs.

1 Like

Good catch. I will have a look at it and report back.

2 Likes