Hubspot->n8n->HTTP Post Workflow works when triggered manually but does not when real trigger event happens

Hello! I am having this issue with 2 workflows that used to work just fine.

My whole automation starts in Hubspot, when a particular workflow changes a particular property.
This property is then used as a trigger to start both n8n workflows, that involve some data selection (with “Set” nodes and so) and then a HTTP Post on another messaging tool, called Helena.

The thing is it worked fine for 1 month and suddenly it stopped working. I no longer see any execution of these particular workflows (other HS envolving Workflows still work just fine).

As mentioned in the title, when I run the workflow manually, it works and triggers the message on the other end of the workflow.

Any help?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

running via n8n cloud.
Version 1.1.1
flow described above

Hi @Pedro_Lima :wave: You might be running into a limitation by Hubspot - If you activate a second trigger, the previous trigger stops working. This is because the trigger registers a new webhook with HubSpot when activated, and HubSpot only allows one webhook at a time. Would this perhaps be the case for you?

1 Like

Hey there! Thanks for your response.

So, I think that is not my case, since there are only 2 workflows, each with only one distinct Hubspot “Contact property changed” trigger. And these triggers are referring to different properties.

One update I should give: My n8n version was running on version 1.1.1. So I updated it, and one of these automations went back to working!
The only problem is one of them is still not executing automatically.
When I test it manually within the workflow, it triggers the whatsapp message in the end of the workflow normally. But, when I activate it and let it roll, it is not executing despite of the trigger being activated correctly beck in Hubspot.

Any idea of what might me happening?

Hi @Pedro_Lima :wave: Glad that updating helped at least partially!

Can you provide an example of the workflow that you’re still running into issues with? That would help a lot with testing :slight_smile: You can copy and paste the nodes from n8n by hitting cmd/ctrl + A and then cmd/ctrl + C, and then paste it over here in a code block :slight_smile:

Ok, so when I updated n8n to the latest version, my problems were solved and all workflows went back to triggering automatically.

But, suddenly, after not even 2 days of them back to normal, ALL workflows stopped working, despite being “active” and showin in the admin that I had 5 active workflows. Their triggers were still happening as usual, but workflows weren’t working.

Then, now, a week later with no executions whatsoever, from any workflow, I decided “turning off then on again” for all workflows, and 2/3 that we were using went back to working, and 1/3 did not.
Observation: For 1/2 of the workflows that did go back to working, we lost this one JavaScript custom code on the “Set” node that filtered the first word of the “Full Name” string that came from hubspot. So we are gonna have to redo the work there, but should be no problem.

So, as of now, we have this one workflow (copied below) that is not working, despite the “contact property changed” trigger working on Hubspot.

When I trigger the workflow manually, it works fine. Then I save it and activate it, and it does not work automatically.
I already checked and this is the only workflow that uses this particular property as a trigger.

Please help me, my stakeholders are already talking about switching to zapier :persevere:

Update: I realized the problem indeed seems to be this limitation by Hubspot. Only one of the two automations that use Hubspot’s “On contact property changed” trigger can work at a time.

This is a huge problem for us, since we have multiple properties that should trigger different messages as their value is changed.

How do you suggest I can overcome this issue?

Below is my current Workflow, with one sets of nodes for each trigger, totalizin 2 lines. I wish both lines would be working at the same time.

@EmeraldHerald some light here?

Hi @Pedro_Lima :wave: Sorry for the delay in response - I was out of office :bowing_man:

There’s really only two ways around it - you could consider building a “catch all” workflow with your Hubspot trigger (receiving all updates, and then possibly calling sub-workflows depending on the type of update it receives).

Alternatively, you can consider creating a second application in Hubspot’s developer portal (and then a second set of Hubspot credentials in n8n based on this new application) for your new workflow. This would get around Hubspot’s limitation.

No worries! You are helping a lot.

About the solutions provided, I’ll be trying the first one, then, if it doesnt work, I’ll try creating other Hubspot Developer integration.

So, about this “catch all” Workflow: How should I set this up? Should I put my "sub-workflows after an “if” node? or should I just conect the 2 current workflows I have (I sent the code above) in one common major trigger?

Hi @Pedro_Lima :wave: You can do a little bit of both of those - you’ll need one Hubspot trigger (since they only allow one active webhook), and then use an If node to split into the two branches for whichever update has occurred. :+1: