I can't acess my n8n

I have n8n installed on my vps and I can start it normally, but when I try to access it in the browser using my IP (0:0:0:0:5678) my browser only shows “Unable to access this site”.
The workflows are working, as I receive messages on Whatsapp from a workflow I have, but I simply cannot access the interface through the browser. Also, the n8n stops working after a while, causing me to need to start it again to keep working.

What should I do?

imagem_2024-01-24_102006958

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @Ryan_MR3 :wave: Welcome to the community! :tada:

If you’re using a vps, you’ll likely need to access it via the IP of the server itself - so instead of localhost, you’d need the IP address of your server and append the n8n port to the end. This would look something like http://192.168.1.1:5678/. For a lot of vps providers, this would be displayed at the top of the tab where you access the console, but it isn’t always the case. It’s not likely that your IP for the server is 0.0.0.0 :sweat_smile:

If that doesn’t help, couple of questions for you:

How are you running n8n, would this be through docker or through npm?
Are you using the default database, or a different one?
What version of n8n are you running?
Could you share your configuration files (please remove anything that might be sensitive like credentials or passwords!)

Also, what vps are you using? All of this information would help greatly!

Hi, @EmeraldHerald !

Regarding using my server’s IP, I am already aware of this. In fact, I was able to access n8n normally until last week, I used 0:0:0:0 just as an example (I think I wasn’t clear about that, I’m sorry)

Regarding your questions:

  • I run n8n through docker
  • I am using default database
  • I use n8n in version 1.24.1, just like in the image
  • I’m using a VPS with Ubuntu 22.04 64bit
  • Where/how can I find these configuration files?
1 Like

Ah, sorry @Ryan_MR3 ! I just figured I’d mention it just to be safe rather than sorry :sweat_smile:

I’m not too sure exactly where it’ll be as it may be different for you, but my hunch would be in your user’s home directory or /root, which should have those configuration files.

Did you change anything since last week, as well? :thinking:

My n8n still worked normally, until I tried (and failed) to install typebot (following this guide: Guia Passo a Passo para Instalar o Typebot em seu servidor próprio - Remontti). Unfortunately, I couldn’t find the configuration files you mentioned.

A couple of things that I’ve noticed while looking into this for you:

  • I just noticed that you’re using n8n start to start your instance, which means that you’re likely using npm, not docker, to start your instance. In this case, it’s likely n8n stops when you close your SSH session.
  • Taking a peek at that blog you linked, you might have had to change some DNS or NGINX settings that could be interfering with n8n running properly, but I wouldn’t be able to say for sure without knowing what settings you’ve changed and what your current configuration looks like.

Just also as a heads up, self-hosting n8n does require some technical knowledge, including:

  • Setting up and configuring servers and containers
  • Managing application resources and scaling
  • Securing servers and applications
  • Configuring n8n

With that in mind, n8n recommends self-hosting for expert users. If you aren’t experienced at managing servers, we’d likely recommend you to try n8n Cloud instead.