I can't connect n8n with miro (client_id is not provided)

Hi There ! I hope you are doing well
I have an issue related to connect http-request node with connect it with miro

I’ve followed the miro documention steps here https://developers.miro.com/reference/create-authorization-request-link and n8n show up error (client_id is not provided).


n8n version: 1.15.2
Database: default
n8n EXECUTIONS_PROCESS setting: default:
Running n8n via: n8n cloud
Operating system: Windows 10

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

n8n version: 1.15.2
Database: default
n8n EXECUTIONS_PROCESS setting: default:
Running n8n via: n8n cloud
Operating system: Windows 10

HI @OHS_Brand, welcome to the community.

This isn’t an error returned by n8n but by Miro and I suspect the message is at least somewhat misleading. The client_id is shown in your first screenshot, so it’s very much present despite the message:

Looking at the documentation you have linked it appears to me the Authorization URL should be https://miro.com/oauth/authorize. Perhaps you want to give setting this URL in n8n a go and verify if this changes anything?