I can't find my file ... :-)

Using the Spreadsheet node to (successfully) write out SQL query results to a spreadsheet. The result is visible in the node and can be downloaded from the execution view as a valid XLSX file. However, subsequent nodes cannot see this file, even though I have saved to a path that has a persistent volume on the host. When I look within the running container, I also cannot find the file. When I look at the persistent (mapped) volume directory on the host, there is no file. I have tried using a filename both with an explicit, absolute path and without (as in the version pasted here). Same result - not found.

I’ve read as many posts on file output that I can find in the forum. I am OK with docker volumes etc. and have tried several (my Postgres instance is persisted to the host for example) yet I just cannot find this file inside or outside of the container. The n8n.log file is persisted and contains no messages relating to this (n8n_LOG_LEVEL is set to warn).

Screenshot attached below

It feels like I am missing something fundamentally simple … Stuck ! :slight_smile:
Any and all advice very welcome.

Error message : “Read Binary File: The file “mdmtasks.xlsx” could not be found

Output returned by the last node

NodeOperationError: The file "mdmtasks.xlsx" could not be found.
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/ReadBinaryFile/ReadBinaryFile.node.js:58:31)
    at async Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/src/Workflow.js:594:28)
    at async /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/WorkflowExecute.js:537:49

n8n setup:

  • n8n version: 0.181.2
  • Database you’re using (default: SQLite): PostgreSQL as a container
  • Running n8n with the execution process [own(default), main]: ?own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: **docker **

Hey @simon.lewis, hope you are well?

Following the Spreadsheet File node, your file would exist in memory but is not written to the hard drive yet. To write it to your hard drive you’d need to use the Write Binary File node (or instead send out the file via email, download it etc.).

Hope this helps!

I knew it would be a simple thing !! Thanks so much @MutedJam