I can't get the Whatsapp Cloud API "send" operation to deliver my message

Hi, I’m trying to use the WhatsApp cloud business integration and I can successfully use the Send Template operation, but can’t make the Send operation work. I tried with a set node to establish the content as a character, but nothing happened. I hope you can help me out to solve this problem as soon as possible.

No error message, just no message showing up in WhatsApp with the number I’m sending to. While if I use the template - using the “Send Template” operation - with the same number, it does work fine.

WORKFLOW:
[

{

“messaging_product”: “whatsapp”,

“contacts”: [

{

“input”: “584261114047”,

“wa_id”: “584261114047”

}

],

“messages”: [

{

“id”: “wamid.HBgMNTg0MjYxMTE0MDQ3FQIAERgSQUUyNUI5RDlEOUNBN0YwQUVCAA==”

}

]

}

]```

![image|690x170](upload://ejrEKZmGwr5lcMCQEKyZOS8jDTZ.png)

Hi @Grupo_Ancla, welcome to the community!

Based on our email conversation it seems the message has been submitted to the Meta API successfully, so you might want to check with them directly why it was not delivered to the end user’s phone.

You might find some of the conversations around the WhatsApp Business Platform outside of n8n helpful, for example this Stack Overflow thread. In addition to possible verification requirements this could be the key here:

I solved it in v14.0 answering the first template message

This is also how this service behaves for me, meaning WhatsApp seems to only allow free text messages after a user has replied to your initial template message.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.