I can't update N8N via docker compose

I’m still on version 0.231.1 and I can’t update beyond that version.

What I’ve already tried:
docker pull docker.n8n.io/n8nio/n8n
docker pull docker.n8n.io/n8nio/n8n:1.7.1
docker pull docker.n8n.io/n8nio/n8n:next
docker compose pull

All commands followed by:
docker compose down and docker compose up -d

It shows pulling the update, but when I turn on my N8N, nothing happened, it’s still on version 0.231.1

What can I do?

Thank you so much guys!

Information on your n8n setup

  • n8n version: 0.231.1
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via: docker compose
  • Operating system: linux

What’s the content of your docker-compose.yml file look like? Specifically for the service definition for the n8n container itself, and it’s image property. My first guess is that it is pinned to 0.231.1, and you need to update it to the version you wish to have it run.


    # https://docs.n8n.io/release-notes/
    image: docker.n8n.io/n8nio/n8n:1.7.1
    [...further service config...]

If that’s the case, right now you’ve simply instructed Docker to download the new images, but not use them to run the container with. Update the image property, and then re-run the docker compose up -d and it should use the new image (it will also pull any images that aren’t already downloaded, so you should be able to skip the manual pull commands in the future).

1 Like

Hello, thank you very much for your help.

I did as you indicated and it is starting, but it hasn’t come back yet, it’s been a few minutes.

I used the “docker ps” command to see if everything was ok and then “docker-compose logs n8n”

Everything seems ok, what do you think? Just look

I went back with the backup and tried upgrading to the next version instead of the last one directly. And it worked for 0.233.1, but when I tried any higher version, it just kept loading again. So I took a printout of the logs, what could it be?

That may be a bit beyond me - I imagine you may need to step through versions a bit to allow for the migrations to happen for each one, but I’m not sure if there are some that you may be able to skip - hopefully someone else (probably from n8n) can provide some guidance!

I’d just make sure you have some backups on-hand in case anything goes wrong.

If you are going from pre 1.0 it can take a while for the process to finish with the database but there are also some other things to take into consideration but while it says it is running the migrations I would leave it as stopping it can cause issues.

Thanks friends for all your help! You guys are awesome!

I’m going to try to migrate version by version and wait as long as necessary, leaving the migrations until dawn. Then I come here to inform you.

Thank you very much!

1 Like

Guys, everything went well. I was able to update manually with the nano docker-compose.yml command and updating the image.

I did version by version, one at a time and managed to get to the last one.

However, I noticed that when trying to use the common docker compose update commands, nothing happens. I will probably always need to manually update the image via docker-compose.yml

Thanks for everything guys!

Hey @joao_muck,

Using the docker compose commands should work but it all depends on what image you are using and if you specify a tag.

Nice to hear you are up and running though.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.