I can't upload via n8n. Can someone help me? please

I’m receiving a file via elevenlabs and trying to upload it via http, but it always gives an error due to the lack of a preset, but I’ve redone the node several times with the help of chatgpt, but nothing works

Where should I add the preset? I can’t do it at all, what should I do? I haven’t been able to for days Sorry if it’s hard to understand, I’m using google translate

I need upload in Cloudinary

Hey @PedroHenrique26,

The Cloudinary API has upload_preset as a required value with the below description.

(Required for unsigned uploading / optional for signed uploading) Name of an upload preset that you defined for your Cloudinary product environment. An upload preset consists of upload parameters centrally managed using the Admin API or from the Upload page of the Console Settings. An upload preset may be marked as unsigned, which allows unsigned uploading directly from the browser and restricts the optional parameters to: public_id, folder, tags, context, face_coordinates and custom_coordinates.

It looks like you might need to do something in the Cloudinary admin portal to create a preset, It might be easier to generate the signature unless you know your way around Cloudinary.

Yes, I’m trying to put the “upload preset” field, but I can’t find how to do that on the n8n, because I’m using the format with binary data to be able to send the file, I’m a little newbie in the subject, could you take mine as a reference flow and show me how do I do this in http node?

  "meta": {
    "instanceId": "9b8c11ec1d7722d48b6973dbf70400faa913ae64e46fef1f40a9b1d654824ea2"
  "nodes": [
      "parameters": {
        "requestMethod": "POST",
        "url": "https://api.cloudinary.com/v1_1/NomeConta/auto/upload",
        "responseFormat": "file",
        "jsonParameters": true,
        "options": {
          "bodyContentType": "multipart-form-data",
          "followRedirect": true
        "sendBinaryData": true
      "name": "HTTP Request",
      "type": "n8n-nodes-base.httpRequest",
      "typeVersion": 1,
      "position": [
      "id": "e8902ab4-c359-47ad-9c6f-953c95f74905"
  "connections": {}

Hey @PedroHenrique26,

It is probably easier to use the newer http request node version so you would have something like the below. Just update the preset with the name or id of the preset you have created.

1 Like

thanks, i love you


I love me too…

Glad to hear it might be working :raised_hands:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.