IF Function returning 'Unknown Error' only on data filtered

Describe the issue/error/question

I have a fairly simple IF function set up. It reads data from a Pipedrive People Get, if the Person’s label in Pipedrive matches any 4 labels specified it outputs as TRUE and of course, the rest are outputted as FALSE. The weird thing is the filter works, in a set of 8 data lines I can see it’s marked 6 as TRUE and 2 as FALSE yet on the FALSE data lines it loses the data and just returns “UNKNOWN ERROR - check the detailed error for more information”.

I have flipped the IF statement so the 2 data lines are TRUE and the rest FALSE yet the 2 data lines are still returning the error and the FALSE 6 return all okay.

What is the error message (if any)?

UNKNOWN ERROR - check the detailed error for more information

Please share the workflow

Share the output returned by the last node



"error": "UNKNOWN ERROR - check the detailed error for more information"



"error": "UNKNOWN ERROR - check the detailed error for more information"



Information on your n8n setup

Running version [email protected]
Running n8n via n8n.cloud

Hey @ditly,

So I think what is happening is the Pipedrive node is returning the unknown error and the if node is just allowing you to see it. Can you share the full workflow?

@ditly can you give this a bash and see if the result is different.

Thanks @Jon unfortunately it’s still returning the same error.

So strange since it does filter too like this:

Hey @ditly,

Does the pipedrive node show any error?

… Ahhhh on the Pipedrive node you have “Continue on Fail” set but there is nothing to check if it did fail, If you add in a couple of Ifs to make sure the correct data is there it should work.

Ah when I turn off “continue on fail” I get this error from Pipedrive, ‘resource not available’ but when searching for the refernced resource which is person 18529 they do exist and it did manage to pull it up in the previous Pipedrive search function.

I’ll keep looking.

"name": "NodeApiError",
"cause": {
"message": "404 - {"status":false,"error":"Unknown method ."}",
"name": "Error",
"stack": "Error: Request failed with status code 404 at createError (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/core/createError.js:16:15) at settle (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/core/settle.js:17:12) at IncomingMessage.handleStreamEnd (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/adapters/http.js:269:11) at IncomingMessage.emit (node:events:532:35) at IncomingMessage.emit (node:domain:475:12) at endReadableNT (node:internal/streams/readable:1346:12) at processTicksAndRejections (node:internal/process/task_queues:83:21)"
"node": {
"parameters": {
"authentication": "apiToken",
"resource": "person",
"operation": "get",
"personId": "={{$json["id"]}}",
"resolveProperties": true
"name": "Pipedrive Get From Email",
"type": "n8n-nodes-base.pipedrive",
"typeVersion": 1,
"position": [
"id": "XXXX",
"credentials": {
"pipedriveApi": {...} // 2 keys
"timestamp": 1660656593256,
"message": "The resource you are requesting could not be found",
"httpCode": "404",
"description": "Unknown method ."

Is all the data coming out of the If node correct?

Hi Jon,

So I haven’t actually been able to identify the core issue but I have fixed it.

I’ve basically broken off the two forks which search via email and phone number and ran them as separate workflows. There was also an issue with the start of the workflow where I wasn’t actually splitting the batches correctly. However I don’t think either was really the issue but in the process of simplifying it I’ve fixed it.

New workflow that works is:

1 Like