I'm private for my company

I am making private nodes for my company I watched the video tutorial below and tested it after the link and checked existed in “C:\Users\Admin\AppData\Roaming\npm\node_modules\n8n\ node_modules” but it doesn’t appear in nodes.

Describe the problem/error/question

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @nhanh102,

We changed the path from v1 and using the node_modules folder is no longer supported. Instead you would need to use the ~/.n8n/custom folder which looking at your path would be something like C:\Users\Admin\.n8n\custom.

I would always recommend checking the documentation as it will contain the latest information.

1 Like

Too bad I don’t understand much of what you’re saying because I’m programming from another language here. Seeing the documents change a lot makes me really helpless in testing, can you give me a simple example of importing json and returning a basic value?

Hey @nhanh102,

Not sure I understand, The issue is with the path you are running the link command in. If you run it in the new path it will work.

You have mentioned JSON though… You are writing your own node and not a workflow right?

That’s right I’m writing my own node, I’m going to send data to the webhook and I’m going to create my own node that processes that data. In fact, I’m going to decrypt it because it’s my financial data.

Hey @nhanh102,

Perfect in that case run the link command in the .n8n/custom folder and you should be good to go.

I’m installing the template and don’t know if I did something wrong in any step

Hey @nhanh102,

The first command you ran (the build) failed so it sounds like you might have missed the install command first to get everything.

I used the demo version but for some reason there were many errors with missing files and folders

Hey @nhanh102,

You might need to update your package.json for the credentials and the nodes, Without seeing your full file structure it is hard to say what is going on.


Hey @nhanh102,

That looks like a lot is missing, Can you share the actual Github repo if it is public?

Hey @nhanh102,

That is not the same as what you published to npm but I will give that repo a quick go and see if it works.

Well actually I just want to make an internal node that allows me to pass a json from a webhook and then process it and return a key:value. I tried here: Install private nodes | n8n Docs. But I don’t see it working

Hey @nhanh102,

Does it need a node for that? You could make a workflow with a webhook then a respond to webhook node that returns a key / value.

Actually, we have a lot of processing services and need security, so using a workflow is inefficient and takes many steps. We just need the customer to install our iot device and send it to the webhook and use our own notes to perform the functions.

Hey @nhanh102,

In that case I would try setting up the node as we describe in our documentation (using /home/node/.n8n/custom) as the path is a good starting point. Are you also running n8n in docker or using npm as that could also change things a bit.

I tried creating folder under /home/node/.n8n/custom and n8n/.n8n/custom unfortunately it still doesn’t work

Hey @nhanh102,

Are you using docker or npm? Have you also managed to build the nodes without an issue?