Increase memory in autohost

Hi

I have increased or I think I have increased the memory of my n8n (I have it autohosted) and I would like to know if I have done it correctly. is there any way to check it?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi,

  • n8n version: [email protected] (last version I think)
  • Database (default: SQLite): I don’t know, so I think that it was SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): Where can i check it?
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker via digitalocean
  • Operating system: Ubuntu

Hey @fval90,

Are you sure you need to increase the memory? How have you attempted to increase it?

Hi @Jon
I think I need it but I’m not sure. I have chopped a workflow into 4 to make it run more optimally but work, but in one I work with 2 JSONs of about 30Mb each. I can’t separate it or perform it by split because of the workflow target.

I can show you my workflows with data examples

Hey @fval90,

If you get an error about memory it could be a good step, You mentioned that you think you have increased the memory did you do it by setting the docker memory option or the nodejs memory option?

Hi @Jon
By setting the docker memory option. How can I check if I have configured correctly?

Thank you

Hey @fval90,

Looking at the Docker documentation it looks like running docker stats n8n would show you how much memory a container with a name of n8n is using and what the limit is.