Increasing the max token of using ChatGPT API

Describe the problem/error/question

It’s only max 3800 tokens for each time using ChatGPT 4 preview and we cannot increase it.
But we also cannot reduce the amount of detail that provides to it.
Is there any solution for solving this problem that you experienced?

More specific, the flow is:

  1. We have to provide detail of business info and campaign direction to the ChatGPT.
  2. After that, the ChatGPT will read it all then generate social idea posts for us.
    So, the output is below 3800 tokens for sure. But the input will be more than that limit, that make the workflow stop to run.

Information on your n8n setup

  • n8n version: 1.26
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main): own
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm
  • Operating system: win

I don’t have as much experience with the AI nodes as some others on here.

But I do not believe n8n imposes any token limits. The token limits are set by openAI in this case. You will need to pick an openAI model that has a higher token limit

1 Like

Yes, it’s on OpenAI.
So, for solving this probelm we have to reduce the input token.
There are some ways to do that is depending on the goal of the workflow.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.