Init Problem

Hello friends,

Whenever I start n8n this error message appears:

init problem
There was a problem initializing the workflow:
Workflow with ID “1” could not be found.

How can I fix it so that it doesn’t happen again?!

Hey @rfdepauli,

That is a bit odd, do you have any workflows saved?

Yes, I have several saved workflows!

Mmm you have a workflow there without a title, have you modified the database at any point or maybe downgraded versions?

This unnamed flow was a test flow that I had created but not finished. I deleted it, closed and opened it again and the n8n and the message appears the same way!

Yes, I made an downgrade in version 0.179.0, which had some bugs. But they have already been fixed and now the n8n is on the latest version (I even updated it today)!

Via which URL do you open n8n? If you for example always open n8n with the URL http://localhost:5678/workflow/1 (the important part is /workflow/1) and the workflow with the ID 1 does not exist then you would and should see exactly this error message.

1 Like

Thank you very much, @jan! The problem was exactly this. I was using the URL as you put it above. I’ve solved it here!

Thank you very much!


Great to hear that this solved your problem.

Have fun!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.