Input 2 on merge node not getting triggered when only connected to node in front

Describe the problem/error/question

I am trying to trouble shoot one of my workflows and when I pulled out the following section, it doesn’t work like it does in the original workflow. The node on input 2 is not getting trigged.

Which makes me think I have been using this incorrectly.

I am trying to replicate a left join.

Original workflow:

Troubleshooting workflow:

Is this expected behaviour?

Many thanks

What is the error message (if any)?


Information on your n8n setup

  • n8n version: Version 1.17.1
  • Running n8n via (Docker, npm, n8n cloud, desktop app): n8n cloud

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

@got_flat , try switching to v0 (legacy) execution order in Settings of the workflow. If using v1 logic, you need those node’s input connected to a node that would trigger them.

See n8n v1.0 migration guide | n8n Docs for the difference between legacy and new execution order.


Thank ihortom.

The below change to the workflow has worked for me.

Is this the best way to do it or there something more elegant?


1 Like

Hey, @got_flat , I’m not aware of any other ways. If adding extra connections looks messy you always can switch to v0 legacy ordering. I have built many workflows with very complex flows. Using v1 ordering becomes almost impossible without interconnecting the nodes in indeed very messy way. Thus, I often use v0. On the other hand, those connections might help to understand dependencies more clearly and they facilitate execution of the nodes in more effective way with v1 ordering. I just hope that n8n team will not deprecate the legacy v0 ordering. I’m convinced that both have the right to be.

1 Like

Thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.