Installation Issue on Termux

Hello!
I’m trying to install n8n using npm globally via Termux
last time n8n is working but it requires update so i decided to reinstall Termux app and reinstall n8n
But i got into new issue.Heres the log file: https://bit.ly/3tkiAIi
Please assist me

Hey @Zolushka,

What commands are you running? I have not played with Termux before but it looks like a limited shell emulator, do you know what the changes were between app versions?

It might be worth trying the older version of Termux to see if that still works.

Both *npm install n8n -g’ and ‘npx n8n’ doesnt work
I’ll attach full screenshot.Btw i linux install method




Hey @Zolushka,

Have you tried the older version of the Termux app or checked what the release differences are? The screenshots are too small to make any sense of but I suspect the issue is more around the emulation of the shell environment than n8n itself.

Could be worth making sure it is using version 14 of Node as well.

i did downgrade termux using old and deprecated one
the issue still exist
EDIT:Im using old and deprecated version of termux (the one i used before updating n8n) still doesnt work

That is a bit odd, Are you able to change the node version in Termux? Do you know what version of n8n you had installed before that was working? It may be worth installing that version again to see if that is working.

Another thing I found when looking at Termux issues with SQlite is you may need to run pkg install clang libsqlite pkg-config before trying to install the node module so it might be worth giving that a bash.

its already latest version,and i did use termux version i installed before and issue still persist
i even use different phone as well
i think the problem is in n8n installation itself bcs last time before i updated n8n its worked,and no matter what kind of termux version,it still working
but now after new n8n updates,it stopped working

Did you install the 3 packages I mentioned? I found the same error message on the Termux issues page for another application so I don’t currently think it is an n8n issue directly.

Did you also try installing the older version of n8n to see if that works?

Yeah i did installed those 3 packanges

idk how to install older version of n8n
please assist me

Do you get the same error with those 3 extra packages installed or something different?

You can install a specific version with the npm command so something like npm install package [email protected]

Do you know which version was working or when you installed it originally?

An updated log file may be useful as well.

Hey,ive tried installed n8n over other (non rooted) phone and still doesnt work
i will attach you full screen record log here
https://drive.google.com/file/d/1VILVTk60d3ijHCUNOpqhZdiwSD6_MDEQ/view?usp=sharing
I dont know how to install older version of n8n and i have no idea the old version of termux ive installed

EDIT:I installed the base version [email protected],0 Still doesnt work

Hey @Zolushka,

That is interesting, I have to ask… Are you sure it ever worked? Looking at that video it still appears to be failing when trying to setup SQLite. What happens if you try to install sqlite through npm does that work?

It could be worth opening an issue with Termux as this doesn’t appear to be directly related to n8n.

heyy uh i did installed libsqlite and those 3 packages you mentioned at first minute of video
i have no idea whats going on,ive tried some youtube tutorial on installing n8n on debian machine etc
seems doesnt work
few months ago while i install n8n i use npx n8n and nothing else,its installed and running smoothly
but now after reinstalling termux (its still same version like before) n8n doesnt seems work
ive tried downgrading nodejs to version 14.x seems no work either
Tried installing sqlite using cmd “npm install sqlite3” doesnt seems work and output some erros
idk if this can be trouble
Sorry im just 15 idk whats is happening

Hey @Zolushka,

I did notice you installed the the sqlite lib which is handy but for some reason as your test has hightlighted when trying to install sqlite3 as an npm package it is failing. This is the GitHub issue I found when looking up your error: Sqlite3 not install · Issue #1511 · termux/termux-app · GitHub it could be that I have missed something in that thread but for now I would suggest chatting to the Termux team as your error exists outside of n8n and I am out of ideas :smiley:

It could be that something in Termux has changed or a change in the Node SQLite package has changed and it no longer supports Termux for some odd reason. From what I understand though Termux is not a full Linux system and is just emulation so with that and running it on a Mobile device I suspect there will be more issues if you do manage to get it installed.

Have you tried using the desktop version if you have access to a computer? That may be a good way to get started.

Desktop version works well but i dont upldated it and its still using version [email protected]
i dont use my computer as n8n server bcs i dont want its online 24/7 just to do automation task
and i cant afford n8n cloud as well
Ive tried running n8n in heroku but it didnt last long bcs im running out of Free dynos hours so yeah
i guess im stuck here for now TwT
Anyway thanks tho,ill keep you updated

You could try Oracle cloud it has a very good free tier and @MutedJam put together a fantastic guide here: Anyone running n8n on Oracle Cloud Free Tier? - #11 by MutedJam which covers how to set it up.

1 Like