Invalid Record Length: expect 1, got 2 on line 3 [.csv with multiline string]

.csv file

first three lines:

007-949-928;LAND;278688470000;27868847;R1-1;Residential Inclusive;H;VAP14122;N;THSL;;3259;WANETA PL;V5M 3H7;LOT H  BLOCK N  SECTION 44  PLAN VA;P14122  DISTRICT LOT THSL  NEW WEST;MINSTER;;;2131000;102000;2023;2000000;104000;1972;1972;8137.31;022;2023
019-003-234;STRATA;650270980238;65027098;CD-1 (167);Comprehensive Development;238;LMS1509;;THSL;300;2418;BROADWAY E;V5M 4T9;LOT 238  SECTION 34  PLAN LMS1509;DISTRICT LOT THSL  NWD PART SW 1/4,;TOGETHER WITH AN INTEREST IN THE C;OMMON PROPERTY IN PROPORTION TO THE;UNIT ENTITLEMENT OF THE STRATA LOT;174000;132000;2023;97600;191000;1994;1994;850.89;021;2023


ERROR: Invalid Record Length: expect 1, got 2 on line 3
NodeOperationError: Invalid Record Length: expect 1, got 2 on line 3
    at Object.execute (/usr/local/lib/node_modules/n8n/packages/nodes-base/dist/nodes/SpreadsheetFile/v2/SpreadsheetFileV2.node.js:142:27)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/packages/workflow/dist/Workflow.js:673:19)
    at /usr/local/lib/node_modules/n8n/packages/core/dist/WorkflowExecute.js:652:53

Running docker langchain beta

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @dRAT3,

That error is the node saying it is expecting 1 column but it got 2, I took a quick look at your data and it looks like line 3 has a , in it which is the default Delimeter for CSV files. Can you try setting the spreadsheet file node to use a ; as the delimeter instead like below and let me know how you get on.

These are the only options I have:

Header Row
Include Empty Cells
RAW Data
Read As String
Sheet Name

Hey @dRAT3,

Assuming you have set the File Format to CSV you might need to update n8n or add the node to your workflow again as I know we only added the option fairly recently.

I pulled the latest docker image for the ai-beta, but still don’t have the option

Hey @dRAT3,

What version of n8n does that show as?

It shows version 1.9.0

Hey @dRAT3,

The latest version of the n8n beta should be 1.18.0, Can you do a force pull of the image that should get it updated.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.