Invisible Characters

I’ve got a project where a user (we haven’t found him or her yet :wink: ) copies invisible characters into their databases. Also still no idea what this character is, but it messes up the workflow that converts json to excel. As a matter of fact, the workflow doesn’t even start (when testing), and apparently the request doesn’t even touches the Webhook node. I’m immediately getting a


Bad Request.

jsonpathfinder actually ‘sees’ this invisible character …

The JSON with the invisible character is:

[
	{
		"invisible_character": "Curcuma longa de ..."
	}
]

Any idea how to trap this error and/or work around it? … other than assuming that an error 400 may be an invisible character :wink:

Hi @dickhoning, my best guess is that your character could be something like unicode character U+2029 (a paragraph separator). This is a character requiring encoding in many applications, not just n8n or the JSON Path Finder website you are using.

So you would most likely need to apply proper encoding before sending this in a webhook as part of a JSON string, for example as suggested here on StackOverflow.

Alternatively, you could consider sending this value using a content type other than JSON. Multipart for example would worked fine when testing this just now:

1 Like

Thanks @MutedJam ! I found the control character …

I do not want to send this character, so I’ll have to filter it out from the data I’m sending from my FileMaker App.

And is there any possibility to get a better feedback for these kinds of situation, other that that you’re getting a error 400 Bad Request?

@MutedJam BTW: got triggered by you using Insomnia … really cool! Up to now I used PAW and Postman to build and test my API calls …

1 Like