Issue with Webhook Call URL Stuck on localhost

Hello everyone,

I’ve recently encountered an issue with N8N while configuring the Webhook Call URL in my workflows. The URL is currently stuck on “localhost,” and I’m unable to modify it within the N8N user interface.

Context:

  • I installed N8N directly on my VPS using Putty, and I access N8N using the IP address of my VPS: http://51.210.242.54:5678/.
  • When I create a Webhook Call node in my workflows, the URL is by default set to “localhost” and is grayed out, preventing me from making changes.

I have the same problem for the Authentification on soma app like Airtable.

Actions Taken So Far:

  1. I’ve tried deleting and recreating the Webhook Call node, but the URL remains stuck on “localhost.”
  2. I’ve checked the configuration in the ~/.n8n/config file and writed this code :
    “tunnel”: {
    “enabled”: false
    }

But it doesn’t worked.

Question: Has anyone else encountered this issue or have any ideas on how to resolve it?

Additional Information:

  • N8N Version: n8n/1.20.0 linux-x64 node-v18.19.0
  • N8N Installation Method: Direct installation by Putty

Thank you in advance for your assistance!

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Nono_Digital_Assets,

Welcome to the community :cake:

It looks like the bit you are missing is the WEBHOOK_URL environment variable, I would remove the config file changes you made and set the environment variable and you will be good to go.