Jira Trigger Error: Node does not catch when issue is created

Hi all,

I have a Jira Trigger node in order to start the workflow when an event is triggered in Jira. This event has to be an issue creation with a specific type.

There is no error, but when I execute the workflow, it waits for the event trigger. I create a new issue with the type filter (I tried it also without any filter) and nothing happens.

I can see that the webhook gets created in Jira. I have admin rights and my credentials are correct in the jira trigger node.

Why could that be? It doesn’t look like it can catch the newly created issue trigger from Jira.

Welcome to the community @Pelin !

If you can see that the webhook did get registered correctly on Jira, I can right now only think of two reasons for it not working:

  1. n8n is not configured correctly and it sets so an invalid callback URL
  2. Jira does for some reason not call it

Regarding 1. You can try to create a Webhook Node and see if calling the webhook URL works correctly (especially from another computer/server).

Also didn’t work…

Then n8n is not configured correctly. If you compare the Webhook Callback-URL and the URL you type in your browser, that will be probably quite obvious.

Generally, make sure to follow the Server Setup Guide to be sure that it is configured correctly.

In your case, I would assume that the environment variable WEBHOOK_URL is not set correctly. A list of all environment variables can be found here.

I understand that when I use the desktop version, I need to follow the Server Setup Guide? Sorry, I’m not very clear on these issues.

I appreciate your help!

I solved the issue now. As you said, n8n wasn’t configured right :slight_smile:

Thank you!

1 Like