Lack of proper OAuth loopback url BUT --tunnel is set and working

Describe the problem/error/question

I have trashed accidentally my working 0.222.1 version updating to latest 0.233.1 (every workflow has gone…) but that lead me to error wanting to recreate my workflow with google sheets. I got --tunnel parameter set running n8n. Console log shows me this url but when I try to do credentials now i don’t have this tunneling url but localhost one which leads me to nothing. Any help guys? I am stuck now with half work done and don’t have idea what to do. I stoped and started container - same thing

n8n ready on 0.0.0.0, port 5678
Initializing n8n process
Waiting for tunnel …
Tunnel URL: https://ns74xnupu0XXXXXXXXXXXXvxdrgc.hooks.n8n.cloud/

IMPORTANT! Do not share with anybody as it would give people access to your n8n instance!
query is slow: SELECT “Settings”.“key” AS “Settings_key”, “Settings”.“value” AS “Settings_value”, “Settings”.“loadOnStartup” AS “Settings_loadOnStartup” FROM “settings” “Settings” WHERE (“Settings”.“key” = ?) LIMIT 1 – PARAMETERS: [“features.saml”]
execution time: 2326
Version: 0.233.1

Information on your n8n setup

  • n8n version: latest 0.233.1
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • Operating system: arm7

Hey @fishaa,

Are you maybe setting the webhook_tunnel_url option? It would the handy to know what your docker command looks like.

Hi!
my whole docker compose file is:

version: “3”
services:
n8n:
image: n8nio/n8n:latest@sha256:dd1347fc89e1daa14bd2a68ee114f418b11b018dafbd1ccf7a6a882433d45634
restart: always
ports:
- “5678:5678”
environment:
- GENERIC_TIMEZONE=Europe/Berlin
volumes:
- ‘~/.n8n:/root/.n8n’
command: “n8n start --tunnel”

it worked with 222.1, now any google auth 2 credentials doesn’t show proper tunneled url, only local one. I have tried to auth with copied from terminal url and submitted to google console where i am making it but it doesnt worked. The console output is in my first post with some anonymization ;).
thanks!

same with n8nio/n8n:0.235.0
in logs console i got fancy url, but in nodes i got http://localhost:5678/rest/oauth2-credential/callback

That is odd and a bit unexpected, for now I would recommend going to an earlier version until we look into this in more detail tomorrow or if this is for a production environment move away from the tunnel option and use your own domain

I’ve reverted to

n8nio/n8n:0.222.1

Digest:sha256:117149fc43f881ee678fba8f356adb75d7196aa9d2ae3e1d6635696b94c5b6f3

and it is working. I got credentials setup window with proper tunel url.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.