License manager not initialized when trying n8n with Postgresql

So, I am trying to migrate to PostgreSQL cause of this
I have seen this guide, and backed up all workflows and cred. using CLI.


  1. I installed PostgreSQL, created a user and a database, both named n8n.
  2. exported all env vars as listed here and DB_TYPE from here
  3. Tried to start n8n.

The following error was displayed:
License manager not initialized

I was not sure what’s wrong, so I created a new VM with fresh Ubuntu and reinstalled everything from scratch.
This time I installed PostgreSQL before installing n8n. Then installed n8n, then set the variables, aaaand got the same error.

What am I doing wrong? Can anyone describe the whole process of setting up n8n with PostgreSQL? Maybe I’ve missed some step or set the wrong var or something…

Information on your n8n setup

  • **n8n version:0.230.3
  • **Running n8n via:n8n start
  • **Operating system:Ubuntu server 22.04.2 lts

I’ve completely forgot to set up a password for n8n user in postgresql.

After this everything worked fine. n8n has migrated to postgresdb.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.