License manager not initialized

I have this problem, when i’m trying to update n8n.
I have sqlite, what i shold to do?

Hi @artemik83 :wave: Sorry to hear that you’re having trouble with this!

Looks like the migration is causing the crash here - are you trying to upgrade? Which upgrade are you running?

You also may not have free space left to handle the migration.

yes, i’, trying to upgrade.
i just run command “docker-compose pull”

Can you let us know how big your database is, and how much free space you have left? If you’re pulling the latest version of n8n, there’s actually some hefty migrations to be done, so you might be running into trouble there.

I think it might have something to do with the fact that I once moved the database from one server to another. I just took the entire .n8n folder and uploaded it to the new server.

But that was back in March, since then everything has worked.
Occasionally, by the way, there were errors that the database was corrupted, but since everything was working, I didn’t pay much attention to it, as the error was only when looking at old completed workflows.

My database has now been 800mb+ for 3 months

unfortunately, i don’t remember which version i had before i started updating the n8n. As far as I remember it seemed to write that my version was out of date by version 9

Can you let us know which version you’re upgrading to from your Docker compose file?

here is screenshot

1 Like

Thanks for that!

Some steps I’d take here:

  1. Roll back to the last version of n8n that was working for you
  2. Create a database backup to be on the safe side
  3. Re-run the migration on a machine that has more space, or after making space on your current machine

That should allow the migration to go through. I’ll also ping our resident database jedi @netroy to see if there might be some more troubleshooting steps I’m missing here :bowing_man:

1 Like

how to know, what version i used before update?

@artemik83 i’m not too sure if you’ve been keeping your n8n images on disk or not, but you can use docker image ls to get a list of all images that you’ve had.

When n8n starts, it also prints a message, such as Version: 0.233.1 - that might be helpful, too if you store logs, gives you something else to check :bowing_man: I believe you could use something like docker compose logs | grep 'Version\:' in this case.

doesnt work
How i can export all workflows from n8n in that condition?

If you can’t access the UI, you can find the CLI commands for exporting workflows here: CLI commands | n8n Docs

i can not use cli commands

Hey @artemik83,

What sort of hardware are you running n8n on? A quick fix could be to try using a sqlite browser to delete old execution_data which should get you back up and running.

You could also try restoring from a backup if you took one before upgrading or maybe changing the image in the compose file to something like n8nio/n8n:0.224.4 and see if that starts up.

1 Like

I have the same problem. The container is in an endless loop. I have already tried a rollback to an older version, but had other problems here that I could no longer access the workflows.

The current :latest does not fix the problem. I have already deleted the entire database and had it recreated. Even with the fresh installation / fresh database I get this error.

Hey @Azathoth,

Which error are you seeing? the License manager message is not something to worry about but what is interesting is deleting the database would normally get things running so it sounds like there is more to your issue. Can you open a new thread and complete the template so we can look into this more.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.