Long wait node time marks the execution as failed although it succeeded

Describe the problem/error/question

Long wait node time marks the execution as failed although it succeeded.

Please share your workflow

Information on your n8n setup

  • n8n version: 1.34.2
  • Running n8n via (Docker, npm, n8n cloud, desktop app): cloud

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

It’s not succeded, according to the screenshot the last node hasn’t been executed.

Have you checked that the node works?

I don’t know, but maybe the cloud instance has build-in limits for the execution time (the env EXECUTIONS_TIMEOUT), maybe @Jon can shed a light

Sorry, I appended the screenshot of the last node. It was executed successfully. I also think, that is has something to do with timeouts. It would be great, if someone could shed a light on this. I might open a bug report on Github?

Ah, I just read that there is an execution timeout after 40 minutes for Cloud Pro. Does it have something to do with this? But then, why is the node still executing? I might add, the variables used in the node have the correct values, although the node shows two errors. I checked my Mautic instance, and the data is there and valid.

It’s a different timeout :slight_smile:
40 minutes is the maximum amount of time that you can set in the workflow settings

But there might be a general timeout for every workflow.

Does all executions get failed after long time waiting? As there may be different reasons (e.g. updating the instance, maintenance windows, etc)

This time, it worked. I will keep looking and update, if this happens again. Thanks!

1 Like