Mailchimp GET Campaign not retrieving any data

Hi guys,

I’m trying to obtain some data regarding a campaign on Mailchimp.
First I run the mailchimp node as below:

This correctly outputs the campaigns I have in my account. Then I take one of the IDs from this output and run the node as below:

The node runs without errors, but there is no output data.

This is the only node (besides start node) on this workflow.

From what I read on the mailchimp API documentation this should not be the case, as this api call returns a lot of different data.

Any clues on what could be going on?

Info:
running version 0.184.0 on a Digital Ocean Server

Describe the issue/error/question

What is the error message (if any)?

Please share the workflow

(Select the nodes and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow respectively)

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]:

Hey @Daniel_Barra,

I have just taken a look and it appears to be working for me.

Could you try updating your n8n install to see if that resolves the issue.

Hey Jon!

Updated and it worked like a Charm.

Thanks for the help.

1 Like