Markdown to HTML, inconsistent output

Describe the problem/error/question

Using Markdown to HTML node to take in markdown text (card description from Trello) and build HTML output. I’ve used this node many times. Trello data is input via webhook (first node in flow) and data passes through a HTTP request node, IF node, then to the Markdown to HTML node.

I’ve triple checked it is set up correctly, with correct input, yet it outputs the exact data from the previous node (IF node) without the HTML output data. It’s simply not present.

If I isolate the Markdown to HTML node (with static text input, no data input from previous nodes), this node functions correctly. Also, deactivating all nodes in the middle, so we have only the webhook input data and the Markdown to HTML node, this node functions correctly.

Even while making the paste-worthy demo for this post, I encountered a second error type:

“error”: “Unexpected token u in JSON at position 0”

Note: I also double-checked that the IF criteria is passing data on the correct path. :white_check_mark:

Any idea why this might be happening? How to fix?


What is the error message (if any)?

“error”: “Unexpected token u in JSON at position 0”

Information on your n8n setup

  • n8n version: 0.188.0
  • Database (default: SQLite): I believe Mysql
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker, although known issue with incorrect install
  • Operating system: linux

Hi @Entrepositive, I am very sorry to hear you’re having trouble. I tried running your example, but it seems the URL in your HTTP Request node doesn’t return any response, with your Markdown node referencing a value of {{$node["Start"].json["body"]["carddescription"]}} which is unfortunately not included in your example data.

Is there any chance you can share an example value for body.carddescription using which your problem can be reproduced (and also the expected HTTP response if this affects the behaviour in your case)?

Thank you!

Hey @MutedJam

Thanks for your response.

I was unable to replicate an identical workflow (without revealing sensitive info), so I wasn’t able to perfectly replicate the problem, unfortunately.

Fortunately, however I did “fix” my own problem, if only functionally. I just moved the Markdown to HTML node before the HTTP request node. This solved my current issue, although it does not address the original problem of the Markdown to HTML node not properly functioning.

Even though the known problem still remains unsolved, I’d say we nix this thread on the grounds that I am not able to reproduce the exact problem in my example here. Thoughts?

EDIT: Although…in my searches on the forum, no other thread specifically addresses this issue. The mystery remains unsolved…


1 Like

If it’s now working (even though it’s with your workaround in place) and considering you are using an older version of n8n I think it might not be worth spending too much additional time on this.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.