Match in an IF not working

I’ve got a json input (from a chain of functions) that has IP addresses in a column ‘ipAddressList’. That comes from an array via Item Lists. I’m trying to separate out the private addresses with IF, ie ‘not contains’ ‘192.168’. I’ve tried not begins with, not contains, etc but the string ‘192.168’ doesn’t match. Data from the input is in a string.

I’ve also tried regex but that doesn’t match with ^192.* or anything similar.

google also isn’t helpful as I haven’t found anyone struggling with this match in an IF


Hey @syadnom, welcome to the community!

If I understand correctly, you’re trying to filter local vs public IP addresses. Is that correct?
Can you provide some sample input data so I can see how you’re trying to separate them?

Also, keep in mind that there are way more private IP ranges than just the ones starting with 192.. Are you trying to filter just these or as many private IP addresses as possible?

yes, but I’m really just trying to remove the the 192’s

Input data looks like this:


but a condition in an IF statement with ‘starts with’ ‘192’ does not match. Nor does ‘contains’
I’m using ipAdressList as value1, contains, and 192 for value2. no quotes or anything though I have tried with ’ and " quotes trying to figure out what the heck I’m doing wrong. This seems so simple… it’s a string, does the string contain or start with these characters…

hi @syadnom

I suppose you forgot to change the input type to “Expression” instead of “Fixed”. Here is an example

1 Like

yeah, I might have. Also, I mupgraded from a really old version to 1.9.3 so I think some of the changes have confused my process.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.