Microsoft Teams - Create Message (beta)

Hello guys!

I have a question regarding MS Teams and the Create Message feature. Has anyone got this working? The Channel features of the node are working properly. But when I want to create a message in a channel, I do get a Error 403 forbidden.

The node uses the beta Graph API. The API says it needs the theses privileges:

I put thos into my setup. Still I can not send a message and get Error 403.

So has anybody successfully sent messages to teams?


Just tested it and it’s working for me. Are you part of the team where you are trying to send the message?

I am part of the team. Can you share your app reg permissions?

Also what I can is, is that in my N8N I can not see my Teams name wher it is at your screenshot. There I see the GUID of my team.

But the Channels are properly listed.

@vuchl this? if it’s not this. Let me know where to find it. I configured the app a long time ago so do not remember a lot.

Yes this! Thank you! The Permissions look good enough then.

We managed to get it working. I have 2 acconts on Azure. One for our domain administration and my personal account. I used my domain admin account to connect via OAuth2. I gave my personal account the permissions and ownership of the app registration, reconnected the OAuth2 credentials in N8N and now I can post maessages!

The problem seems to be that the org account is not a member of the channel and therefore can not post. with my personal account it works like a charm.

Thanks man!

Glad that it worked. Let us know if you have other questions.

Now the team name resolution also works! Topic can be marked as solved