Migration failed after update

Describe the issue/error/question

I updated my n8n instance from 0.191.0 to 0.192.0. After the new Docker Image is created i get a error message:

What is the error message (if any)?

Migration "AddJsonKeyPinData1659895550980" failed, error: pinDataPerNode.every is not a function
There was an error initializing DB: "pinDataPerNode.every is not a function"

Information on your n8n setup

  • n8n version: 0.192.0
  • Database you’re using (default: SQLite): sql
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker
  • I create my own Docker Image and use it inside Home-Assistant - its more or less a default instance

Do you need more Infos from my side?
Can i run the migration my self? How?

Best Regards

Hi @niefuend, I am very forry to hear you’re having trouble. Could you try upgrading to the latest n8n version instead? A fix for the migration you’re having trouble with was released with [email protected], so let’s hope the latest version works for you.

Moin @MutedJam,
thanks for the fast reply. it worked for me and i updatet to the latest version.

best regards

1 Like

Awesome, glad to hear. Thanks so much for confirming!