Multiple-words props not working in Compare Datasets skipping

Describe the problem/error/question

In Compare Datasets we can mention props not to compare. When a prop contains multiple words, it looks like [‘Prop A’].

The problem is that unlike one word props, these props are ignored and comparison is made.

What is the error message (if any)?


Please share your workflow

The difference is that two upper sets use different names for the prop: TestA and Test A. If you run the workflow, in the first case the output goes to the Same gate, in the second - to the Different gate. Because in the 2nd case the prop is failed to skip and is being used in comparison.

Share the output returned by the last node

Just launch the example

Information on your n8n setup

  • n8n version: 0.233.1
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu 22

Hi @artildo :wave: I’m not so sure that’s intentional - I’ll create a ticket internally to have the team look into this and report back to you when I have any more information.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.