My Google Sheets Trigger node error when Trigger On: Row Updated

My Google Sheets Trigger node shows an error when I try to use Trigger On: Row Updated
But it works with Trigger On: Row Added

I do believe that there are no issues with permissions

Describe the issue/error/question

What is the error message (if any)?

Problem in node ‘Google Sheets Trigger‘
Missing permissions for Google Sheet

Please share the workflow

Information on your n8n setup

  • n8n version: Cloud

Hey @iamarsenibragimov,

It does look like a permission issue, It could be worth connecting the account again and just making sure that you have permission to edit the file.

@Jon thank you for the answer. I’ve reconnected my Google account twice and double-checked that I’m the owner of the file with obviously editing rights and the issue still occurs.

Can we somehow investigate the problem?

Hey @iamarsenibragimov,

I am not sure what else to check, I have done some testing and for me it is working as expected. Can you try making a new file and see if you get the same issue with that? What version of n8n is your cloud instance running on?

I have the same problem: the google sheet trigger node work with trigger on Add but not with Row updated.

The message is the same of @iamarsenibragimov

n8n version: 0.220.0
installed as docker container on a our server with CapRover

Same issue here: when I select Trigger On: Row Added, it works.

Row Updated or Row Added or Updated do NOT work.

UP, I got the same issue even while I check if i got both credentials Google Drive and Google Sheets. And of course I got the right autorisations.

Hey @Jean_WILLAME,

If you use a normal Google Sheets node does it let you read and write from the sheet using the same credentials?

I just test it rn. My google sheet normal node is working and I just put theses credentials in the google sheet triggers node and the error is exactly the same.

So my initial thought is something still needs to be done on the Google Side which is why we display the permission denied message. Sadly though we cut out the full message which is normally something like…

Google Sheets API has not been used in project $foo before or it is disabled. Enable it by visiting$foo then retry. If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry.

Yeah I tried to remove it on te google cloud console and update it again but there’s still the same problem… This feature is so nice and I was expecting so much from it but I guess i’ll have to do the call API by my self and not using the trigger node…

1 Like

Ok I finnaly fix it and it’s work, I just desactivate and reactivate some API from the google cloud store : Docs, Slide, Drive and Sheets.

I tried it again and it work ! Thanks for the help @Jon that was the good things to do :slight_smile:

1 Like

Hi everyone,
I too solved it even if I don’t know which of the steps was ok.
I removed Google sheets API, but doesn’t work.
So I removed Google sheets API and account, then I re-enabled API and create new account. But nothing.
I add Google drive API and finally the issue is fixed.

Thanks to all

1 Like

@Mauro_G THANK YOU! I was about to quit n8n over this one, it is indeed the Google Drive API you need to activate…Thanks. :slight_smile:

Hi. I just want to contribute after having a lot of trouble to make this work.
Even after disabling and enabling the Google Sheets API and Google Drive API (inside Google Cloud Services), it still wasn’t working.
So i discovered that inside Admin Console (Admin Console → Apps → Google Workspace → Service Status) the service “Drive and Documents” was disabled.
I hope this information can help somebody in the future (and I’m sorry about my English, not my mother language)

1 Like

Welcome to the community @vitrineperfeita, and thank you so much for sharing your first-hand experience here. I’m sure this will help quite a few folks!

I just solved this problem. You need to enable Google Drive API and Google Sheets API.

Activate this API that works!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.