My N8N "blew the server" out of nowhere

## Describe the problem/error/question
Folks, my N8N has exploded in server usage and is 1 day over 100% disk capacity. I installed it on my own server via Docker Compose and tried to update and restart it, but it didn’t work. I’ve been using it for several months and I’ve always been updating. Can anyone help me understand what I can do? Or is there a way to deactivate the flows via command in the view console so that I can identify if one is generating this? I’m not a programmer…

Thank you

Information on your n8n setup

  • n8n version: 0.231.1
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via Docker
  • Operating system: Linux

Hey @joao_muck,

Welcome to the community :tada:

That looks a bit busy, Can you get into the container using docker exec that would then let you run the command quickly to disable all of the workflows.

Hi Jon, thank you very much.

Well… now my N8N stop function.

My N8N spiked CPU usage on 8/19/23 at night and dropped for 2 days. I updated the linux and tried to update the N8N, however, it continued in version 0.231.1, but it worked again.

Today 08/22/2023 it went off again at noon and fell. I tried the same process, but this time, despite keeping about 30% CPU usage, it just didn’t work again.

We’ve tried updating it, restarting it, restarting the container, restarting the server, going back to a previous version (0.230.3) and also changing the “EXECUTIONS_MODE” to “main”, and none of that worked, it’s still down.

What can we do? Thank you very much.

Hey @joao_muck,

Have you disabled the workflows and enabled them one by one to see which one may be causing the issue? Are you also running anything else on the server or is it just n8n and docker?

Hi, thanks for always getting back to me.

We managed to bring it back by bringing it to a previous version, 0.231.1. Then I increased the size of the machine to have more memory. (Yes, we only run N8N and docker on the server)

At this moment it is working and occupying little of the CPU. I searched the run history and didn’t find any abnormal flow. Before, when I tried to update the N8N to the latest version and it kept crashing. I tried 2 ways and both didn’t work.

The first was using the commands
docker-compose pull
docker-compose down
docker-compose up -d

The second attempt was with the commands
docker pull
docker-compose down
docker-compose up -d

I’m thinking of trying again now, but first I’d like to know:

  • Is there a different way to update it from 0.231.1 to 1.3.1?
  • It seems to me that the N8N is taking up too much memory. Is there anything I should periodically delete, like run history or something along those lines? If yes, how should I do it?

Thank you so much always! God blesses!

Hey @joao_muck,

Your upgrade process is pretty much what I do, A pull then down / up -d. n8n will use some memory while it does the migration going to the new version but for general running it shouldn’t use more than normal.

Normally with things like this it could be that a workflow is pulling in a lot more records than before or there is a loop somewhere that is not being handled correctly.

There were also a number of changes in v1 so it might be worth checking the migration guide so you cna make sure none of the changes are impacting your flows.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.