My params is not appear in http response

Hello, I am a Beginner.

I need to send an http request with the text extracted from a mail in gmail.

In the Http request, I send the parameter

  "flow": "a625eebc-c091-4a0c-bb96-6d5b779b3a1e",
  "contacts": ["142f3cf0-2d45-47c9-9763-d95a9c4f33df"],
  "Parameters": {"1": "{{$node["Array"].json["1"]}}"}

But in the response the Flow is registered, also the contact, but the parameter not

Does anyone know why this problem is?

Here I show the documentation.

This is an example of response, I think that i put the correct code, but i still have the same bug.

try doing JSON.Stringify($json.1)

oh I see you aso gave the documentation.
The params arent an array like you put it in. So that is probably what is going wrong then.
You are sending an array where it expects an object.

ps. it might still want you to stringify it instead of sending the actual Js Object.

1 Like

Hi BramKn.

I tried whith the param like an object, in fact i tried whith a simple text acord whit documentation, and have the same result.

imagen

Have you tried using fields that actually exist? I don’t think a field called 1 exists.

The field have not to exist, it will create.

Here show an example, on postman, the fiel appear like

"params": {
    "1": "Parametro de prueba"

Hi @C3sar_S, from looking at your screenshots it seems you are using a rather old version of n8n. Are you also facing this problem when using the current 0.211 version of n8n? And could you perhaps share the exact JSON data structure (the values themselves can of course be redacted if they contain any sensitive information) you are passing on to your HTTP Request node as well as the HTTP Request node itself so we can reproduce your problem?

1 Like