My Workflow does not end

Describe the problem/error/question

Hello !

I noticed that since Friday 4th, some of my worklfows does not end. They do work perfectly and have the intended resutlts but when I check the current executions, they are still running.

I can’t check how the execution is going and if I cancel the execution, I do not have any log about how it went.

What is the error message (if any)?

No error message, just running continuously. No changes were made to those workflows on the 04/10.

Please share your workflow

The following workflow is just aimed to put some information from a e-commerce website into a google sheet.

Share the output returned by the last node

I sadly don’t have the input but here is a screenshot of my current executions on this workflow ^^.

Information on your n8n setup

  • n8n version: Cloud
  • Database (default: SQLite): Google Sheet
  • n8n EXECUTIONS_PROCESS setting (default: own, main): ???
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):**Cloud
  • **Operating system:**Windows

hi @Romain_Mangattale

you can enable the timeout workflow option in the workflow settings in order to force it to run into an error and get logs

1 Like

Hello !

Thanks for the advice. Sadly, my workflow does not seem to stop running permanently. I set up a limit of 40 minutes to remain large and I see that the recent executions still are running past 100 minutes.

Would you have another workaround ?

that setting will be applied only to the new executions started after the modification. You can manually stop the previous executions

Sadly, I was talking about the new executions that went on after I had put the timeout threshold. So even with this new parameter, I still have executions that continues to run past this limit.

hm… sounds weird.

One suggestion is to disable the Respond to Webhook node and see if the execution will end normally.
Next suggestion is to disable the Google Sheets node and check if the execution will end normally

Maybe something weird is happening with google sheets node, or maybe that e-commerce site receive your webhook response, send something back to the workflow, that will respond to the response and so on…

Or maybe workflow has stuck at Response node

Yes, definitely weird.

I have tried to disable each of the node except the trigger, my workflow still goes on and on.

I tried to create a new workflow and copy-paste another version but I have the same behavior. It definitely looks like a N8N glitch at this point sadly, should I send a request to the support ?

same here 1.9.3. infinite running


Can anyone help ? I can’t monitor my workflows anymore nor make sure that my executions went right.

I tried to create a new workflow and it seems that this behavior enters when I add the webhook trigger.

It does not seem to have problems as I respond right away.

Hi @Romain_Mangattale, I am so sorry for the trouble.

Unfortunately I couldn’t find an n8n cloud instance under your forum email, but based on your description I wonder if you might be affected by a bug fixed with n8n version 1.11.1 where the final execution status isn’t written as expected to the database under certain circumstances.

This would lead to the behaviour you have reported where the workflow works and you’re getting the expected response, but the execution still shows up as “running” afterwards.

Can you try upgrading to n8n 1.11.1 via your n8n cloud dashboard and confirm if this problem still happens for newly started executions afterwards?

1 Like

Hello !

Thanks for the advice it worked and my workflows have finally stopped running !

Have a good day !

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.