MySQL node ETIMEDOUT error

Hi! I was using a lot of MySQL query node. It worked for weeks, but now I got ETIMEDOUT error in all of them since tomorrow.

I talked with my server and they said that everything is okay there. I can access normaly my DB via MySQL Workbench, but I can’t no more with n8n.

Any idea how to solve it or what happened?

I already tried to check credentials, everything is okay.
The DB is openned for any IP too.

That’s my error

Error: connect ETIMEDOUT
    at Object.createConnection (/usr/local/lib/node_modules/n8n/node_modules/mysql2/promise.js:242:31)
    at createConnection (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/MySql/v1/GenericFunctions.js:37:30)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/MySql/v1/MySqlV1.node.js:254:74)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:653:28)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:592:53

Hey @Igor_do_palido_ponto,

A timeout is a timeout, for some reason the connection or query is not completing. If it was all working then it stopped the first thing I would check is what has changed? Was n8n upgraded? Was the database upgraded? Did the database server get restarted? Is this happening for all queries or just larger ones?

1 Like

Nothing was changed in server or the data base.
It is happening in all queries, even the very tiny ones.

Server said that nothing was changed and I can acces the db with Workbench normally.

Must be something here in N8N. Its my final chance

Hey @Igor_do_palido_ponto,

Sadly ETIMEDOUT is normally network issue so it could be that n8n isn’t sending a message or getting one back, Typically though I wouldn’t expect something like this to just start happening so I suspect there may have been a change that no one thinks is relevant.

How do you have n8n deployed at the moment and what version are you using? When you ran MySQL Workbench was it from the same machine (or container) running n8n?


I tried the last stable and the last version. Both same thing.

Yes, I tried to query from two different machines and in both I have sucess in Workbench, but not in n8n

Hey @Igor_do_palido_ponto,

Do both the machines you tried from have n8n running on them? Can you also tell me how you have n8n deployed?

I’ve disabled my DB firewall and entered with credentials. Worked for weeks.

@Igor_do_palido_ponto is that related to the last 2 questions or is it working now you have disabled the firewall?

Since the beginning was disabled.

I am not sure what you mean.

The DB firewall was always disabled. Nothing changed there.

Ah ok, I was confused as the firewall sort of came out of nowhere and wasn’t something mentioned.

If it isn’t working still can you answer the last 2 questions I asked so we can work it out?