N8n 1.x not starting well

Just updated from 0.x to 1.x but the command which usually works successfuly fails with:

Error: command n8n not found

The command I use:

sudo docker run -it
–restart always
–name n8n
-p 5678:5678
-v ~/.n8n:/root/.n8n
n8n start --tunnel

But something starts since before I can use the command again I have to stop and remove the container.

Pls. help.

Hey @daniello,

From version 1 you need to run the command below… There is no need to specify the n8n command anymore and the volume path has changed from /root/.n8n to /home/node/.n8n

sudo docker run -it \
–restart always \
–name n8n \
-p 5678:5678 \
-v ~/.n8n:/home/node/.n8n \
n8nio/n8n \
start --tunnel 
1 Like


Thanks … but …

“docker: invalid reference format.”

@daniello I might have messed something up with the \

1 Like

this seems to work:

sudo docker run -it
–restart always
–name n8n
-p 5678:5678
-v ~/.n8n:/home/node/.n8n
start --tunnel

1 Like

I think this not working because even if this start still showing localhost on webhooks

Also this should be updated in documentation because there is old info about tunnel.

But i found that there is also error running by docker:
sudo docker run -u root --name n8n -p 5678:5678 -v ~/.n8n:/home/node/.n8n n8nio/n8n

Trying :next and :lastest and the same problem

TypeError: First argument must be a valid error code number
    at Sender.close (/usr/local/lib/node_modules/n8n/node_modules/ws/lib/sender.js:162:13)
    at WebSocket.close (/usr/local/lib/node_modules/n8n/node_modules/ws/lib/websocket.js:301:18)
    at pushValidationMiddleware (/usr/local/lib/node_modules/n8n/dist/push/index.js:91:20)

Thanks for your great work!

I solved error by clean docker

sudo docker system prune -a

But also is problem because even i start on my localhost with tunnel

sudo docker run -d -u root --restart unless-stopped --name n8n -p 5678:5678 -v ~/.n8n:/home/node/.n8n n8nio/n8n start --tunnel

There is in webhook localhost

I’m using raspberry pi in my localhost, everything working fine only tunnel not, there is no error when i run -d flag in docker. also use 1.0.5 v

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.